Instalación de HandyCache paralelo a Mikrotik 2017

Manual actualizado al 19/01/2017….

HandyCache funciona en entorno windows (xp, vista, 7, 8, 8.1 y 10) ya sea 32 o 64 bits, de manera personal sugiero usarlo en windows 7 de 64 Bits

Esquema de Instalación:

 

Reglas Básicas utilizadas:
Agregar una puerta de enlace a nuestra red destinada al Server Proxy
/ip address
add address=10.0.0.1/24 interface=PROXY

10.0.0.1/24: es la puerta de enlace para HandyCache (según imagen)
PROXY: es el nombre de la interfaz de red en Mikrotik que va hacia el server HandyCache

Creando Lista de Ips y redireccionamiento Transparente:
Primero Creamos la lista de clientes
/ip firewall address-list
add address=192.168.10.0/24 list="Clientes Internet"

192.168.10.0/24: es todo el rango IPs de nuestros clientes LAN, Si tenemos más rangos de clientes, bastará con repetir la regla con los rangos que queramos adicionarles y el redireccionamiento los tomará de manera automática ya que son “Clientes Internet”

Ahora hacemos el redireccionamiento:
Existen algunas maneras pero detallaré solo 2
1ra Forma – Simple Nat:
Esta es la forma más simple y limitado a solo 400 conexiones del único handycache que tendrían corriendo
/ip firewall nat
add action=dst-nat chain=dstnat comment=”Redirect Handycache” dst-address=!10.0.0.222 dst-port=80,8080,8888,8880,8777,3477,33301 protocol=tcp src-address-list=”Clientes Internet” to-addresses=10.0.0.222 to-ports=1010
2da Forma PCC Nat:
En esta Forma se puede usar cuantos Handys quieran usar, aumentando así el número de conexiones, pondré como ejemplo 4 Handys corriendo en el server (4 x 400 conexiones = 1600 Conexiones) Uds tendrán que abrir 4 Handys en su server con distintos puertos escucha yo usaré los puertos 8080,8181,8282 y 8383
/ip firewall nat
add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-port=80,8080,8888,8880,8777,3477,33301 per-connection-classifier=both-addresses-and-ports:4/0 protocol=tcp src-address-list="Clientes Internet" to-addresses=10.0.0.222 to-ports=8080
add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-port=80,8080,8888,8880,8777,3477,33301 per-connection-classifier=both-addresses-and-ports:4/1 protocol=tcp src-address-list="Clientes Internet" to-addresses=10.0.0.222 to-ports=8181
add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-port=80,8080,8888,8880,8777,3477,33301 per-connection-classifier=both-addresses-and-ports:4/2 protocol=tcp src-address-list="Clientes Internet" to-addresses=10.0.0.222 to-ports=8282
add action=dst-nat chain=dstnat comment="Redirect Handycache" dst-port=80,8080,8888,8880,8777,3477,33301 per-connection-classifier=both-addresses-and-ports:4/3 protocol=tcp src-address-list="Clientes Internet" to-addresses=10.0.0.222 to-ports=8383

per-connection-classifier: La redirección será dividido en 4 (según nuestro ejemplo) si ud desea más conexiones bastará con aumentar la cifra a 5, 6, 7, etc…
to-addresses: IP de nuestro server HandyCache
to-ports: Puertos de escucha de handy conforme al número de handys abiertos en nuestro Server (en nuestro ejemplo son 4 Handys). si ud aumentó más de 4 reglas para más conexiones aquí también deberá ir aumentando los puertos….ejemplo: 8484, 8585, 8686, etc..

Marcando paquetes con diferentes tamaños para Full Cache:
/ip firewall mangle
add action=mark-connection chain=postrouting comment=HandyCache content="Server: HandyCache" new-connection-mark=handy-connection protocol=tcp src-address=10.0.0.222
add action=mark-packet chain=postrouting comment=handy-packs-small connection-bytes=0-256000 connection-mark=handy-connection new-packet-mark=handy-packs-small passthrough=no protocol=tcp
add action=mark-packet chain=postrouting comment=handy-packs-medium connection-bytes=256001-512000 connection-mark=handy-connection new-packet-mark=handy-packs-medium passthrough=no protocol=tcp
add action=mark-packet chain=postrouting comment=handy-packs-large connection-bytes=512001-0 connection-mark=handy-connection new-packet-mark=handy-packs-large passthrough=no protocol=tcp

Connection-bytes: marca el tamaño del paquete para determinar como será soltado por el Full Cache

Ahora el Fullcache:
Aquí asignamos cuanta velocidad tendrá cada cliente de full Cache segun el tamaño del archivo asignado en las reglas Mangle superiores:
/queue type
add kind=pcq name=HandyCache_Large pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=3M pcq-src-address6-mask=64
add kind=pcq name=HandyCache_Medium pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=5M pcq-src-address6-mask=64
add kind=pcq name=HandyCache_Small pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=10M pcq-src-address6-mask=64

pcq-rate: velocidad que se le asigna a cada uno de los clientes por tamaño de paquetes

/queue simple
add max-limit=10M/10M name=HandyCache_Small packet-marks=handy-packs-small queue=default/HandyCache_Small target=""
add max-limit=10M/10M name=HandyCache_Medium packet-marks=handy-packs-medium queue=default/HandyCache_Medium target=""
add max-limit=10M/10M name=HandyCache_Large packet-marks=handy-packs-large queue=default/HandyCache_Large target=""

max-limit: Aquí asignamos la velocidad máxima que alcanzará la salida Full Cache por tamaños de paquetes y está optimizado para redes Wifi en 5 Ghz, en redes 2.4 se debe trabajar con menores velocidades y en redes LAN con mayores (pcq-rate y max-limit) .. (solo manejenlo según sus necesidades)

En caso de usar HotSpod
Al usar hotSpod en mikrotik las reglas Simple queue de full Cache tendrán la tendencia de bajar al último lugar dejando sin eficacia las mismas, para que esto no ocurra, programamos a mikrotik para que cada 10 segundos ordene nuestras reglas siempre arriba de todas en un orden específico..
/system scheduler
add interval=10s name=schedule1 on-event="/queue simple move [/queue simple find name=\"HandyCache_Small\"] [:pick [find] 0]" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-time=startup
add interval=10s name=schedule2 on-event="/queue simple move [/queue simple find name=\"HandyCache_Medium\"] [:pick [find] 1]" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-time=startup
add interval=10s name=schedule3 on-event="/queue simple move [/queue simple find name=\"HandyCache_Large\"] [:pick [find] 2]" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-time=startup

Desactivar redirección en caso se apague nuestro server HandyCache:
Para ello implementamos esta otra regla Netwatch:
/tool netwatch
add comment=Handycache disabled=no down-script="/ip firewall nat set [find comment=\"Redirect Handycache\"] disabled=yes" host= 10.0.0.222 interval=2s timeout=2s up-script="/ip firewall nat set [find comment=\"Redirect Handycache\"] disabled=no"

Deben de tener habilitado la respuesta Ping en su Windows, si no saben como hacer Sigan está Guía Habilitar “solicitud echo entrante ICMP” para PING en Windows XP, 7/8.1
También se activa al desactivar Firewall de Windows

Bloqueo de QUIC (Quick UDP Internet Connection) de Google Chrome (Manteniendo http)

/ip firewall filter add action=drop chain=forward comment="Bloqueo udp Chrome" dst-port=80,443 protocol=udp

Con Todo Esto ya tendremos todo listo para Trabajar con nuestras versiones de HandyCache…

32 responses to “Instalación de HandyCache paralelo a Mikrotik 2017”

  1. Edwin dice:

    Grosoooooo ayúdame a marcar el tráfico https

  2. Argenis Blanco dice:

    Apoyo 101% este proyecto. Pensé que este proyecto quedaría aquí.
    Éxitos genio.

  3. Mario Guerra dice:

    con ese redireccionamiento es necesario poner el wpad

  4. alonso dice:

    que es el jv reflector?… algun video del funcionamiento de handy cache version de pago?

    • JVProducciones dice:

      es un reflejo de una pagina web solo se cambia el dominio, gracias a eso es que podemos volver a tener a youtube en http….. pronto haré un video

  5. francisco almeida dice:

    me gustaria queme ayunde a configurar este proxy rn mi isp me parece muy bueno
    tengo siertas dudas y me gustaria que me ayuden con eso gracias

  6. victor dice:

    saludos, como puedo adquiri la version de pago…. gracias.

  7. ruben espinoza dice:

    buenas amigo tu instalas handy cache via teamweiver soy de caracas venezuela

  8. Michael Marin dice:

    Hermano tenia todo funcionando y de a la noche a la mañana dejo de hacer cache de https y hay varias personas con el problema en el foro de alterserv te han escrito 2 personas esta misma semana con el mismo detalle. Por favor que podemos hacer?

  9. parker dice:

    how about this? because i’ve 100+ clients.

    add action=dst-nat chain=dstnat comment=”Redirect Handycache” dst-port=80,8080,8888,8880,8777,3477,33301 per-connection-classifier=both-addresses-and-ports:2/0 protocol=tcp src-address-list=”Clientes Internet” to-addresses=10.0.0.222 to-ports=8081-8086

    add action=dst-nat chain=dstnat comment=”Redirect Handycache” dst-port=80,8080,8888,8880,8777,3477,33301 per-connection-classifier=both-addresses-and-ports:2/1 protocol=tcp src-address-list=”Clientes Internet” to-addresses=10.0.0.222 to-ports=8087-8092

    thanks…

  10. pablo mesia dice:

    buenos dias , tengo mi mikrotik en la lan1 ip=192.168.10.1/24 , lan 2 ip=192.168.2.1/24 , lan3 ip= 192.168.5.1 este ultimo es hotspot para conectar esos 3 puertos como le aria o tendria que activar 3 veses andycache

  11. HECTOR ALVAREZ dice:

    hoye tengo problemas me da error de privacidad no me deja navegar por las paginas como resuelvo el error de certificado y error de privacidad

    a esperas de tu respuesta-

    no es se si valio la peno poder pagarlo

  12. […] Es compatible con cualquier versión de handycache en producción configurado con el manual “HandyCache paralelo a Mikrotik“. […]

  13. Brayan dice:

    BUENAS AMIGO CUANTO SALE EL PROGRAMA EN MONEDA LOCAL

  14. saul Lazaro dice:

    cuanto me cuenta la licencia de handycache y como lo consigo soy de peru

  15. saul Lazaro dice:

    como consigo el programa completo y que me ayuden a configurar al 100% soy de peru

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *