Balanceo de 3 wan con un RB 750G con PCC

Fuente: http://www.ryohnosuke.com/foros/index.php?threads/900/

Autor: Nukeko

Publicado19 Ago 2011

Saludos, después de buscar buscar… buscar hice un balanceo algo tosco pero funcional con 3 Wan en mi caso 2 de una misma operadora y la tercera de otra operadora (2 de cantv y 1 de inter, en venezuela) en fin el código es basado en el famoso balanceo en PCC

les iré indicando el código paso a paso…

primero deben tener ya la configuración básica de su mk, en mi caso el balanceo va con 3 WAN y 1 Local en Ip adress solo configuro la direccion de la local 192.168.2.0/24 las de las wan por ser dinámicas las colocara automáticamente, cualquier duda solo pregunten, seguimos…

[​IMG]

lo siguiente es configurar los mangle y el nat, primero el mangle

CODE, HTML o PHP Insertado:
/ip firewall mangle
add action=mark-connection chain=prerouting disabled=no dst-address-type=!local \
    in-interface=local new-connection-mark=wan2_pcc_conn passthrough=yes \
    per-connection-classifier=both-addresses:3/0
add action=mark-connection chain=prerouting disabled=no dst-address-type=!local \
    in-interface=local new-connection-mark=wan1_pcc_conn passthrough=yes \
    per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=prerouting disabled=no dst-address-type=!local \
    in-interface=local new-connection-mark=wan3_pcc_conn passthrough=yes \
    per-connection-classifier=both-addresses:3/2
add action=mark-routing chain=prerouting connection-mark=wan1_pcc_conn \
    disabled=no in-interface=local new-routing-mark=wan1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=wan2_pcc_conn \
    disabled=no in-interface=local new-routing-mark=wan2 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=wan3_pcc_conn \
    disabled=no in-interface=local new-routing-mark=wan3 passthrough=yes

quedaria algo asi…
[​IMG]

luego el NAT

CODE, HTML o PHP Insertado:
/ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface=wan1
add action=masquerade chain=srcnat disabled=no out-interface=wan2
add action=masquerade chain=srcnat disabled=no out-interface=wan3

que quedaria algo asi…
[​IMG]

ahora, agrega los DHCP CLIENT de cada una de tus WAN

[​IMG]

ok teniendo ya esto vamos a las ip Route, allí agregaras el siguiente código OJO debes cambiar las direcciones que correspondan con cada una de tus WAN, allí debes colocar las gateway de cada una no su IP

CODE, HTML o PHP Insertado:
/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    190.207.160.1 routing-mark=wan1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.1.1 routing-mark=wan2 scope=30 target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=200.8.25.1 \
    routing-mark=wan3 scope=30 target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=255.255.255.0 scope=30 \
    target-scope=10

quedaria algo asi….
[​IMG]

(nota adicional sobre la distancia de las routes:

Las distancias se los dejo a criterio yo las coloque en uno (1) todas ya queda a criterio personal como las quieran colocar, aca les dejo la explicacion por Ryo sobre eso

Explicacion rapida por Ryo
Linea1: 512k -> distance: 1 -> 20% conexiones
Linea2: 1M -> distance: 2 -> 30% conexiones
Linea3: 2MB -> distance: 3 -> 50% conexiones

Imagina que se cae la linea2, entonces qué va a pasar? si tienes failover, pues toda la carga, que sería el 30% de las conexiones, se irían a la ruta de menor distancia, en este caso sería a la Linea1.

Entonces, si acomodas las distancias de acuerdo a la relación “mayor velocidad – menor distancia” estás asegurando cierta estabilidad en caso de falla.)

una vez hecho esto usa un gestor de descargas puede ser el download accelerator y metele carga para que veas como trabaja en el winbox, a mi me anda al pelo, si alguna de las wan no te esta dando kb revisa que el gateway de esa wan sea igual al que colocaste en el Ip -> Route, cualquier duda pregunten espero les sea de ayuda….

desde Venezuela

One response to “Balanceo de 3 wan con un RB 750G con PCC”

  1. alexander dice:

    gracias por comparti esa informacion y que tal funciona ese balanceo

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *